
RIGGING: 
 

Skeletons are the underlying joint and bone hierarchies that let you animate your characters. Every 

skeleton has several parent joints and child joints, and one root joint. Parent joints are joints that have 

joints below them in the skeleton’s hierarchy. For example, an elbow is the parent of the wrist and the 

child of the shoulder.  

The root joint is the first or top joint in a skeleton’s hierarchy.  

 

Forward Kinematics (FK) 

With forward kinematics, you transform and key joints directly, rather than using an IK handle to 

animate a skeleton. 

Forward kinematics are useful for creating detailed arcing movements, but not very intuitive for goal-

directed movements. For example, you can easily use FK to animate the rotation of an arm at the 

shoulder joint, but not the arm reaching for a glass.  

 

Inverse Kinematics (IK) 

With inverse kinematics, you transform and key an IK handle to animate a skeleton. The IK handle is 

drawn as a straight line between the start and end joints of its IK chain. The effect the IK handle has 

on the joint chain depends on the type of IK solver used by the IK handle. Inverse kinematics are 

useful for goal-directed movements. For example, you can use IK to animate an arm reaching for a 

glass of water, but not for specific movements at individual joints.  

 

Blending IK and FK 

Instead of using only FK or IK to pose and animate a joint chain, you can use both FK and IK on the 

same joint chain. The Ik Blend attribute on the ikHandle lets you apply FK and IK animation to the 

same joints. Ik Blend specifies the amount of influence (weight) that FK or IK have over the animation 

of the joints. 

Blending IK and FK is useful for posing complex characters that have a wide range of movements in 

their animations. For example, you can use IK to animate the directed motion of a character’s arms, 

and you can use FK to animate the rotation of the shoulder, elbow, and wrist joints in the arm.  

 

Joints and bones 

Joints are the building blocks of skeletons and their points of articulation. Also, joints have no 

shape and therefore can not be rendered. Each joint can have one or more bone attached to 

it, and more than one child joint. Joints let you transform a skeleton when posing and 

animating a bound model. 

Bones do not have nodes, and they do not have a physical or calculable presence in your 

scene. Bones are only visual cues that illustrate the relationships between joints. 
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Anatomical joint types 

Various joint attributes determine how joints behave. By adjusting the attributes of a joint, 

you can limit how far a joint can rotate or restrict what planes it can rotate about. For 

example, to create a joint chain that moves and rotates like the human neck, you would set 

the degrees of freedom for the joints so that they rotate about only 2 axes and then you 

would limit each joints range of rotation.  

Ball joint 

A ball joint is a joint that can rotate about all three of its local axes. For example, the human 

shoulder is a ball joint. 

Universal joint 

A universal joint is a joint that can rotate about only two of its local axes. The human wrist is 

a good example of a universal joint, though the wrist has limitations on the extent it can 

rotate. 

Hinge joint 

A hinge joint is a joint that can rotate about only one of its local axes. For example, the 

human knee is a hinge joint. 
 

Joint chains 

A joint chain is any group of joints and their bones connected in a series. Joints are connected 

linearly, and their paths are drawn on screen by the bones. A joint chain begins at the highest joint in 

the chain’s hierarchy, and its bones are drawn pointing down the chain. 
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When you create a joint chain, the position of each joint should approximate the anatomical positions 

of the joints of the character you are trying to create. For example, if you are creating joint chains for 

the skeleton of a human biped model, you should place the joints at points of articulation such as the 

elbows, knees, ankles and so on. 

 

Skeleton hierarchy 

A skeleton hierarchy is composed of a series of joints and joints chains with hierarchical relationships. 

Each joint in a skeleton hierarchy is a child joint and a parent joint. 

 

A parent joint is any joint higher in a skeleton’s hierarchy than any of the other joints that are 

influenced by that joint’s actions. Joints below a parent joint in the skeleton hierarchy are called child 

joints. Joints at the top of bones are always parents, and joints at the bottom of bones are always 
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children. Parent joints drive the transformations of their respective child joints. Thus, when you 

translate or rotate a parent joint, you also translate or rotate all of its child joints. 

The root joint is the highest joint in a skeleton’s hierarchy. A skeleton can have only one root joint. 

You can move and orient the entire skeleton in world space by translating and rotating the root joint. 

 

Understanding the attributes of a joint 

As you set up joints for posing and animation, there are several attributes of the joint node to 

understand. To change these settings, you can select a joint in the scene, then edit the node using 

the Attribute Editor. 

Limits 

Joint Limit Information attributes specify the minimum and maximum translation, rotation, and scaling 

values for a joint. You can set a joint’s limits if you want the joint to behave in a specific manner. 

For example, to create an elbow joint for a human skeleton, you need to set its rotation limits so that it 

cannot rotate in X and Z, but can rotate only a specified amount in Y. Alternately, you can turn off 

transformation channels or use Set Driven keys to restrict the transformations of an object.  

Degrees of freedom 

If you are planning to use Inverse Kinematics (IK) to pose your joints, you may want to set the 

degrees of freedom for your joints. The Degrees of freedom tool setting determines which local axes 

the joints can rotate around during IK posing and animation. You can set the degrees of freedom for a 

joint from the Joint section of the joint node attributes. 

Damping and stiffness 

You can set the damping and stiffness for joints that are influenced by IK. The damping and stiffness 

values let you specify how joints behave when posed by an IK handle. 

Joint damping applies resistance to a joint as it approaches its joint limits. Instead of the joint abruptly 

stopping when it reaches its limits, you can use damping to slow it down smoothly. Depending on the 

strength and range you set, a joint with dampening will not reach its limit boundary unless forced. For 

most living creatures, when a joint rotates as far as it can, it tends to slow down or dampen before 

reaching its limit. For example, an elbow does not snap straight, but gradually slows down as the 

lower arm aligns with the upper arm. In animation terminology, this type of effect is called an ease-in. 

Joint stiffness specifies a joint’s resistance to rotation during inverse kinematics (IK) posing. Set the 

stiffness value for a joint only if you want certain joints in a joint chain controlled by an IK handle to 

rotate less freely than others. For example, you can set the stiffness of joints in the mid-back of a 

human character so that they rotate less freely than those in the lower back. The higher the stiffness 

value, the less the joint will bend. 

You have to set the Stiffness value for all the joints in a joint chain in order for stiffness to work 

properly because stiffness calculations are relative between joints. 

Local axes orientation 

You can set the orientation of your joint’s local axes to maintain symmetry in your character’s 

skeleton. For example, if you create a joint chain for the right arm of a character, you can then mirror 

the joint chain to copy it for the left arm. You then align one of the joint’s local axes with the bone so 

that it is pointing down the joint chain. This ensures that the joint chain will behave properly when you 

apply IK. 
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Preferred angles 

In a skeleton, each joint’s preferred angles indicate the preferred rotations of the joint during inverse 

kinematic (IK) posing. When you build a skeleton, draw the joints so that they are oriented at the 

angles you would want them to move in during IK. 

For example, if you are drawing a joint chain for the leg of a human character, draw the joints so that 

the bends in the joint chain properly represent the angles of the limb in its rest position. The pose at 

which you set a skeleton’s preferred angles is called the rest pose. Then, when you set the Preferred 

Angle attributes for the leg joint chain, the bend at the knee joint will be set as its preferred angle for 

IK posing. 

 

Create a joint or joint chain 

Before drawing joints or a joint chain, you first need a model in which to place them. For information 

on creating models, see NURBS Modeling or Polygonal Modeling. 

To set the Joint Tool settings 

1. In the Rigging menu set (press F3), select Skeleton > Joint Tool > . 

The Joint Tool settings panel appears. 

2. Adjust the Joint Tool settings as desired. 

To create a joint or joint chain 

1. In the Rigging menu set (press F3), select Skeleton > Joint Tool. 

2. In a view, click on the location in your model where you want to create a joint. 

TIP: Click to create joints, middle-click and drag to move the last placed joint. 

3. Click again in the model where you want to create the next joint in your joint chain. 

A bone appears between the first and second joints. 

4. Continue clicking in the view until you create all the joints for your joint chain. 

5. Press  or  to complete your joint chain. 

To create a joint or joint chain that is automatically centered in the model 

1. Click the Snap to Projected Center icon  on the Status Line to enable centering mode. 

2. In the Rigging menu set (press F3), select Skeleton > Joint Tool. 

3. In a view, click on the location in your model where you want to create a joint. 

The joint is automatically centered in the model. 

NOTE:If your model has multiple mesh layers, centering mode minimizes displacement and 

places the joint in the center of the layers. 

4. If desired, use the Move Tool to re-position the joint. 

The joint is dynamically centered in its new position. 

5. Click again in the model where you want to create the next joint in your joint chain. 

A bone appears between the first and second joints and the second joint is also centered in the 

model. 

6. Continue clicking in the view until you create all the joints for your joint chain. 
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7. Press  or  to complete your joint chain. 

 

Create symmetric joints or joint chains 

To set the Joint Tool settings 

1. In the Rigging menu set, select Skeleton > Joint Tool > . 

The Joint Tool settings appear. 

2. In the Joint Settings section, set the axis of symmetry by selecting X-axis, Y-axis, or Z-axis from 

the Symmetry drop-down list. 

Symmetry is Off by default. 

To create symmetric joint(s) 

1. Click the location in the model where you want to place your joint. 

TIP:Turn on Snap to Projected Center  before creating a joint to automatically center it in 

your model. 

The first joint, the source joint, is created. A second joint, the driven joint, is also created and is 

constrained to the source joint by a symmetry connection. 

NOTE:In the current implementation, the Translate, Rotate, Scale, Rotation Order, and Joint 

Orient attributes are connected. All other joint attributes are not connected and stay independent. 

 

All driven joints and joint chains appear pink so they can be easily identified. 

2. Click again in your model where you want to create the next joint in your joint chain. 

A bone appears between the first and second joints. 

TIP:Use Insert to move the active joint during creation. 

3. Continue clicking until you create all the joints for your joint chain. 

4. Press  or  to complete your joint chain. 

Now when you modify the source joint, the driven joint updates symmetrically. 
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Insert Joint Tool 

Lets you add an additional joint to an existing joint chain.  

 

Insert joints 

To place a joint in an existing joint chain 

1. In the Rigging menu set (press F3), select Skeleton > Insert Joint Tool. 

NOTE: 

 The Insert Joint Tool does not have tool settings. 

 You can insert joints into the joint chains of skinned characters. However, for the newly 

inserted joint to influence the skin, you need to add it to the skin as an influence (Skin > Edit 

Influence > Add Influence). 

2. Click the joint you want as the parent of the new joint, and then drag it to where you want to place 

the new joint. 

3. Repeat step 2 until you finish inserting all the joints you want. 

4. Press  or . 

Bones for the inserted joints are automatically oriented along the axes of the joint chain’s existing 

bones. 

If you inserted joints into the skeleton of a bound character, the character’s bind pose 

automatically adjusts and its skin history is retained. 

 

Connect joints 

To connect joint chains by combining joints 

1. Click the parent of the joint chain you want to connect to another joint chain. 
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2. In another joint chain or skeleton,  + click on the joint that will replace the previously 

selected joint and become its joint chain’s parent. 

NOTE: The joint that you select can not be a root joint. 

 

3. In the Rigging menu set (press F3), select Skeleton > Connect Joint > . 

The Connect Joint Options window appears. 

4. Turn on Connect Joint. 

Connect Joint connects joint chains by combining the two selected joints; where the first joint 

selected is combined with and replaced by the second joint. 

5. Do one of the following: 

 Click Connect to merge the selected joints. 

The Connect Joint Options window closes. 

 Click Apply to merge the selected joints. 

The Connect Joint Options window remains open. 

 Click Close to disregard the options window’s settings. 

The Connect Joint Options window closes. 

 

If you connected a joint to the skeleton of a bound character, the character’s bind pose 

automatically adjusts. 

To connect joint chains by connecting selected joints with a bone 

1. Click the parent of the joint chain you want to connect to another joint chain. 
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2. In another joint chain,  + click on the joint that will be the previously selected joint chain’s 

parent. 

NOTE: The joint that you select can not be a root joint. 

 

3. In the Rigging menu set (press F3), select Skeleton > Connect Joint > . 

The Connect Joint Options window appears. 

4. Turn on Parent Joint. 

Parent Joint connects joint chains by creating a new bone between two selected joints; where the 

first selected joint is the child joint and the second joint is its parent. 

5. Do one of the following: 

 Click Connect to connect the selected joints with a bone. 

The Connect Joint Options window closes. 

 Click Apply to connect the selected joints with a bone. 

The Connect Joint Options window remains open. 

 Click Close to disregard the options window’s settings. 

The Connect Joint Options window closes. 
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If you connected a joint to the skeleton of a bound character, the character’s bind pose 

automatically adjusts. 

 

Mirror joint chains 

NOTE: 

You can not create a mirrored duplicate of a joint chain using Edit > Duplicate with a Scale of 

-1. Use Skeleton > Mirror Joint instead. 

To mirror a joint chain 

1. Select the parent joint of the joint chain you want to duplicate. 

2. In the Rigging menu set (press F3), select Skeleton > Mirror Joint > . 

The Mirror Joint Options window appears. 

3. In the Mirror Across options, select the plane across which you want the joint chain 

mirrored. 

These options represent the plane whose origin is at the joint chain’s parent joint. 

4. Set the Mirror Function. 

5. If you want to rename the mirrored (duplicate) joints, enter their old names in the Search 

For box and their new names in the Replace With box. 

6. Do one of the following: 

 Click Mirror to duplicate and flip the current joint chain in the specified plane. 

The Mirror Joint Options window closes. 

 Click Apply to duplicate and flip the current joint chain in the specified plane. 

The Mirror Joint Options window remains open. 

 Click Close to disregard the options window’s settings. 

The Mirror Joint Options window closes. 

The joint chain is mirrored across the selected plane whose origin is at the joint chain’s 

parent joint. 
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Orient a joint’s local axes manually 

To manually orient a joint’s local axes 

1. Select the joint whose local rotation axes orientation you want to set. 

2. Select Display > Transform Display > Local Rotation Axes. 

The current joint’s local rotation axes appear. 

3. Click  in the Status line (toolbar) to turn on the Select by component type mode, 

then -click the  Select Miscellaneous components icon and turn on Local Rotation 

Axes. 

You can now select the local rotation axis of your joint. 

4. Select the local axis. 

 

5. Do one of the following: 

 Select and use the Rotate Tool (hotkey: E) from the Tool Box. 

 

Orient a joint’s local axes automatically 

To automatically orient a joint’s local axes 

1. Select the joint whose local rotation axes orientation you want to set. 

2. Select Display > Transform Display > Local Rotation Axes. 

The current joint’s local rotation axes appear. 

3. In the Rigging menu set (press F3), select Skeleton > Orient Joint > . 

4. In the Orient Joint Options that appear, set the options you want. 
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If you turn on Orient Children of selected joints , the Orient Joint Options apply to the 

selected joint(s) and all child joints. This can make it easier to apply a consistent set of 

joint orientation settings to a large joint hierarchy. 

5. Click Orient to reorient the current joint’s local rotation axes using the current settings 

and close the options window, or click Apply to apply the settings and keep the Orient 

Joint Options open. 

 

Reroot skeletons 

You can change a skeleton’s hierarchy by changing which joint is its root joint. This process 

is called rerooting. You can reroot a skeleton early in its creation to test the skeleton’s 

behavior with different roots. 

 

To reroot a skeleton 

1. Select the joint in your skeleton you want as the new root. 

If you select the child of the entire joint chain, the skeleton’s hierarchy will reverse. 

If you select a joint in the middle of the skeleton, two separate hierarchies below the root 

joint will be created. 

2. In the Rigging menu set (press F3), select Skeleton > Reroot Skeleton. 

 

Set preferred angles 

NOTE: If you want an entire joint chain or skeleton to assume its preferred angles, select the parent 

joint of your joint chain or the root joint of your skeleton. 

To set a joint’s preferred angles 

1. Select a joint. 

2. Select Skeleton > Set Preferred Angle > . 

3. In the Set Preferred Angle Options, set the options you want. 

To make a joint assume its preferred angles 

1. Select a joint. 

2. Select Skeleton > Assume Preferred Angle > . 

3. In the Assume Preferred Angle Options, set the options. 

NOTE: You can also set a joint chain or skeleton’s Preferred Angle values by -clicking the 

chain or skeleton, and then selecting Assume Preferred Angle from the marking menu that 

appears. 

Disconnect joints 

You can disconnect joints in a skeleton to separate joint chains. The joint that is disconnected 

becomes the root joint of a new skeleton. 

 

www.a2zpapers.com
Download free old Question papers gndu, ptu hp board, punjab board

w
w
w
.
a
2
z
p
a
p
e
r
s
.
c
o
m

www.a2zpapers.com

a2zpapers.com

file:///F:\MayaHelp2016_enu\index.html%23!\url=.\files\GUID-4A54F1FC-0120-4AE1-8CFC-B2CFFC490D3D.htm
http://a2zpapers.com/
www.a2zpapers.com
http://a2zpapers.com/


NOTE: 

 If you disconnect a joint in a joint chain that has an IK handle, the IK handle will be deleted. 

 You can not disconnect a root joint. 

 You can disconnect the joints of a character with a bound skin without having to detach its skin. 

To disconnect joints 

1. Select the joint you want to disconnect. 

2. Open the Rigging menu set (press F3). 

3. Do one of the following: 

 Select Skeleton > Disconnect Joint. 

 -click the joint. 

A marking menu appears. 

 Select Actions > Unparent. 

The bone between the current joint and its parent joint is removed. 

The joint disconnects from its skeleton and becomes the root of a new skeleton. 

 

Remove joints 

NOTE: 

 You can only remove one joint at a time. 

 You can not remove a root joint. 

 You can remove joints from the skeleton of a character with a bound skin without having to detach 

its skin. 

To remove a joint 

1. Select the joint that you want to remove. 

2. In the Rigging menu set (press F3), select Skeleton > Remove Joint. 

The joint is deleted from your scene and the bone of the joint above the removed joint now connects 

to the joint below the removed joint. 

If you removed a joint from the skeleton of a bound character, the character’s bind pose automatically 

adjusts and its skin history is retained. 

To remove a parent joint and all its children 

1. Select the joint that you want to remove. 

2. -click the joint and select Actions > Unparent from the marking menu that appears. 

The bone between the current joint and its parent joint is removed. 

3. Press . 

The current joint and all its child joints are deleted from your scene. 
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Inverse Kinematics (IK) 

With inverse kinematics (IK), you move an IK handle to pose an entire joint chain. An IK handle is an 

object you can select and move that affects the joints it is assigned to. A joint chain that has an IK 

handle is called an IK chain. When you pose and animate a joint chain with an IK handle, the IK 

solver automatically rotates all the joints in the IK chain. The IK solver is what Maya uses to calculate 

the rotations of all the joints in the IK chain when you position the IK handle.  

 

IK handles 

In an IK chain, the joint where the IK handle begins is called the start joint and the joint where the IK 

handle ends is called the end joint. All the joints between the start and end joints are driven by the IK 

handle and its solver. In the scene view, the IK handle is drawn as a line from the start and end joints 

of the IK chain. 

The end of the IK handle, which is located at the last joint of the IK chain by default, is called the end 

effector. When you move the IK handle, the IK solver uses the end effector’s position and orientation 

in its calculations to rotate the joints in the IK chain accordingly. The end effector tries to follow the IK 

handle’s position at all times. However, depending on the rotational limits and fully extended length of 

the IK chain, the end effector might not be able to reach IK handle. 

To move the IK handle to the end effector’s position, use Key > IK/FK Keys > Move IK to FK (in 

the Animation menu set.) 

 

NOTE: 

The IK handle’s end effector can only be viewed from the Hypergraph. 

To create an IK handle, use the IK Handle Tool or the IK Spline Handle Tool. See IK Handle 

Tool and IK Spline Handle Tool. 

General IK handle components 

To show all the current IK handle’s components, see View all IK handle components. 

Handle Wire 

The handle wire is the line that runs through all the joints and bones in a joint chain controlled by an 

IK handle. The handle wire begins at the start joint’s local axis and ends at the end joint’s local axis. 

To view an image of the handle wire, see Rotate Plane IK solver. 

Handle vector 

The handle vector is the line drawn from the start joint of the IK chain to the IK handle’s end joint (end 

effector). This is the axis used by the rotate plane. 
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To view an image of the handle vector, see Rotate Plane IK solver. 

 

Create IK handles 

To create an IK handle on an existing joint chain 

1. Do one of the following in the Rigging menu set: 

 Select Skeleton > Create IK Handle. 

 If you want to change the IK Handle Settings first, select Skeleton > IK Handle Tool > . (See 

also Specify the IK Handle Tool settings.) 

For example, you can use the IK Handle Tool Settings to select the IK solver you want to use 

to calculate the orientation of the joints in chain. 

2. Your cursor changes to the tool crosshair. 

3. Click the joint to use as the IK handle start joint. 

4. Click the joint to use as the IK handle end joint. 

The IK handle displays on the joint chain, connecting the start and end joints you selected. 

 

Disable or enable IK handles 

To disable an IK handle 

1. Select the IK handle you want to disable. 

2. Do one of the following: 

 -click the IK handle and select Disable ikHandle from the marking menu that appears. 

 Select Skeleton > Disable Selected IK Handles. 

The selected IK handle is now disabled. When an IK handle is disabled, it no longer drives its 

target joints and it can not be edited. 

To enable an IK handle 

1. Select the IK handle you want to enable. 

2. Do one of the following: 

 -click the IK handle and select Enable ikHandle from the marking menu that appears. 

 Select Skeleton > Enable Selected IK Handles. 

The selected IK handle is now enabled. 

 

IK solvers 

IK solvers are the mathematical algorithms behind IK handles. IK solvers calculate the rotations of all 

the joints in a joint chain controlled by an IK handle. The effect an IK handle has on a joint chain 

depends on the type of IK solver used by the IK handle. By default, Maya loads the following IK 

solvers: 

 Single Chain IK solver (ikSCsolver) 

 Rotate Plane IK solver (ikRPsolver) 

 Spline IK solver (ikSplineSolver) 
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You can use the spline IK solver only in conjunction with a spline IK handle. See Tips for working 

with spline IK handles and IK Spline Handle Tool. 

 Human IK solver (hikSolver) 

The human IK solver is only used by characters that have been characterized. You cannot use 

the hikSolver with regular IK handles. 

In addition to the default solvers you can also manually load, then create the following solvers: 

 2 Bone IK solver (ik2Bsolver) 

 Multi-chain IK solver (ikMCsolver) 

 Spring IK solver (ikSpringSolver) 

If you want to pose and animate joint chains that have between two and four joints, use single chain 

or rotate plane IK. 

If you want to pose and animate longer joint chains, use spline IK. If you want to pose and animate 

simple three joint IK chains for use in games, use 2 bone IK. 

By default, each IK handle you create that uses the same type of IK solver, also shares the same IK 

solver node. For example, all IK handles that use single chain IK also connect to the same ikSCsolver 

node. Consequently, if you edit the attributes of the shared IK solver node, all the IK handles that 

connect to the node are affected. If you want to fine-tune the IK solvers for certain IK handles only, 

while not affecting other IK handles, you can create additional IK solvers for your IK handles using 

the createNode MEL command. 

 

Difference between single chain and rotate plane IK handles 

The difference between a single chain IK handle and a rotate plane IK handle is that the single chain 

IK handle’s end effector tries to reach the position and the orientation of its IK handle, whereas the 

rotate plane IK handle’s end effector only tries to reach the position of its IK handle. Since the rotate 

plane IK handle’s end effector only tries to reach the position of its handle, the resulting joint rotations 

are more predictable. For the rotate plane IK handle, the orientation of its entire joint chain is 

controlled by the twist discmanipulator. For more information, see the Twist disc description in the 

topic Rotate Plane IK solver. 

NOTE: If your joint chain suffers from flipping, use the rotate plane solver instead of the single chain 

solver. The rotate plane solver was introduced with the pole vector to control the flipping of IK chains 

that you sometimes get with the single chain solver. 

Single Chain IK solver 

A single chain IK handle uses the single chain solver to calculate the rotations of all the joints in the IK 

chain. Also, the overall orientation of the joint chain is calculated directly by the single chain solver. 
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Single Chain IK handle components 
 

Rotate Plane IK solver 

The rotate plane solver is ideal for posing joint chains (such as arms and legs) that you want to stay in 

the same plane. For example, the shoulder, elbow, and wrist joints of an arm driven by a rotate plane 

IK handle all stay within the same plane as the elbow rotates. The plane itself can be rotated from the 

shoulder joint by the pole vector. 

 

A rotate plane IK handle uses the rotate plane solver to calculate the rotations of all the joints in its IK 

chain, but not the joint chain’s overall orientation. Instead, the IK rotate plane handle gives you direct 

control over the joint chain’s orientation via the pole vector and twist disc, rather than having the 

orientation calculated by the IK solver. The single chain solver and rotate plane solver differ in this 

respect. See also Difference between single chain and rotate plane IK handles in the topic IK solvers. 
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See also Pole vector and Twist disc descriptions, below. 

Rotate Plane IK handle components 

Twist disc 

The twist disc is a manipulator that you can use to twist or rotate the joint chain. The twist disc 

is located at the end joint of the IK chain. 

Translating the pole vector often leaves the IK chain pointing in the wrong direction. You can 

use the twist disc to re-orient the plane after you move the pole vector to prevent flipping. 

Joint chain plane 

The joint chain plane is the plane that contains all the joints in the joint chain and poses 

through the axis. The joint chain plane rotates about the handle vector. When you manipulate 

the pole vector, you are rotating the joint chain plane about the handle vector. 

Reference plane 

For the joint chain plane to rotate and twist the joint chain, the plane must rotate relative to 

some other plane so that the degree of twist can be measured. The plane that the joint chain 

plane rotates relative to is the reference plane. 

Pole vector 

The pole vector is a manipulator that lets you change the orientation of the IK chain. The pole 

vector also lets you control flipping. 

Since moving the pole vector changes the orientation of the reference plane, moving the pole 

vector can also change the orientation of the joint chain directly; just as manipulating the twist 

disc can change the orientation of the joint chain. This is because the joint chain’s degree of 

orientation—or twist—is defined as the difference in orientation between the reference plane 

and the joint chain plane. 
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WARNING: 

When positioning your IK handle, if the handle vector and the pole vector cross each other or 

point in exact opposite directions, the joint chain can suddenly flip. You can prevent this 

flipping by moving the pole vector so that the handle vector does not cross it or point in the 

opposite direction from it. 

Rotation disc 

The rotation disc is an indicator that displays how much the IK chain has been rotated by the twist 

disc. The rotation disc is located at the start joint of the IK chain. 

Reference plane indicator 

The reference plane indicator is the green dot on the rotation disc that moves to reflect the 

movements of the pole vector. 

Twist indicator 

The twist indicator is the green arc between the reference plane indicator and the joint chain 

plane indicator on the rotation disc. The twist indicator displays the orientation of the joint 

chain relative to the reference plane. 

Joint chain plane indicator 

The joint chain plane indicator displays the orientation of the joint chain plane relative to the 

reference plane. The joint chain plane indicator appears in the rotation disc. 

 

Spline IK solver 

Use spline IK for posing and animating long, sinuous joint chains like those for tails, tentacles, 

snakes, necks, spines, and similar objects. 
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Spline IK handles let you pose a joint chain using a NURBS curve. When you manipulate the curve, 

the handle’s spline IK solver rotates the joints in the chain accordingly. 

See also Tips for working with spline IK handles . 

Spline IK handle components 

 Twist disc 

For more information, see the Twist disc description in the topic Rotate Plane IK solver. 

 Roll disc 

The roll disc is a manipulator that lets you roll or rotate the entire spline IK joint chain. The roll disc 

is always at the spline IK handle’s start joint. The roll disc is similar to the rotation disc and pole 

vector. See  

 

Create spline IK handles 

A spline IK handle lets you control a joint chain with a NURBS curve. All joints driven by the spline IK 

handle stay on and follow the curve. The spline IK handle gives you additional attributes, such 

as twist, for additional control over the orientation of the joints in your joint chain. 

To create a spline IK handle and automatically create the spline IK NURBS curves 

1. Select your joint chain. 

2. In the Rigging menu set (press F3), select Skeleton > Create IK Spline Handle > . 

3. In the IK Spline Handle Tool settings that appear, turn on Auto Create Curve. 

4. Specify the Number of Spans for the spline IK curve. 

5. Click the start joint for the spline IK handle. 

6. Click the end joint for the spline IK handle. 

The spline IK handle and a NURBS curve appears on the joint chain. 

To create a spline IK handle using a pre-existing NURBS curve 

1. Draw a NURBS curve along the path of the joint chain. 

Create a simple curve with no sharp bends to ensure the joint chain moves smoothly when you 

animate the curve. 

If you create a curve with few CVs, your control of the curve’s shape and skeleton’s movement 

will be less precise, but you’ll be able to manipulate the curve and its joint chain more easily. 

See also Components of NURBS curves. 

2. Select your joint chain. 

3. In the Rigging menu set (press F3), select Skeleton > Create IK Spline Handle > . 

4. In the IK Spline Handle Tool settings, turn off Auto Create Curve. 
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5. Click the start joint for the spline IK handle. 

6. Click the end joint for the spline IK handle. 

7. Select the NURBS curve. 

The spline IK handle appears on the joint chain. The joints in the chain rotate to follow the shape 

of the curve 

 

Pose joints with spline IK curves 

To manipulate the CVs of the spline IK NURBS curve 

1. Select the NURBS curve. 

2. Turn on Display > NURBS > CVs. 

3. Turn on Display > NURBS > Hulls. 

4. Select a CV on the NURBS curve. 

TIP: For easier manipulation of the curve, create clusters of the curve CVs. See Create cluster 

deformers. 

5. Do one of the following: 

 Select the Move Tool (hotkey: w) from the Tool Box. 

 From the Modeling menu set, select Curves > Edit Curve Tool. 

6. Drag a CV. 

This moves the spline IK joint chain. 

To create a cluster deformer for each CV on the spline IK NURBS curve 

1. Select the spline IK curve. 

2. From the main menu bar, choose Select > Cluster Curve. 

This creates a cluster deformer for each of the spline IK curve CVs. 

To twist and roll the spline IK joint chain 

1. Select the spline IK handle. 

2. Select Modify > Transformation Tools > Show Manipulator Tool. 

The twist and roll circular manipulators appear at the start joint and end joints of the spline IK 

chain. 

3. Do the following: 

 To roll the entire joint chain, drag the circular manipulator at the start joint. 

 To twist the joint chain, drag the circular manipulator at the end joint. 

 You can also adjust twist and roll by selecting the spline IK handle and entering values 

for Roll and Twist in the Channel Box or Attribute Editor. 

To slide the joint chain along the curve 

1. Select the spline IK handle. 

2. In the Attribute Editor, select the ikHandle node tab. 

3. In the IK Solver Attributes section, turn on Root On Curve. 

This constrains the start joint of the spline IK handle to a position on the curve. It also provides an 

offset manipulator to slide the start joint along the curve. 
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4. Select Modify > Transformation Tools > Show Manipulator Tool. 

The offset manipulator appears at the start joint. 

 

5. Do one of the following: 

 Drag the manipulator to slide the joint chain along the curve. 

If you drag the start joint to the end of the curve, the child joints move off the end of the curve 

in a straight line. 

 

 Enter values for Offset in the Attribute Editor to move the root of the spline IK chain along the 

curve. 

NOTE: 

 You cannot drag the manipulator past the ends of the curve. 
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 If you turn Root On Curve off, the Offset attribute is ignored. 

To translate, rotate, and scale the spline IK curve 

1. Select the spline IK curve, then select the Move Tool (hotkey: w), Rotate Tool (hotkey: e), 

or Scale Tool (hotkey: r) from the Tool Box. 

Use the manipulators that appear to translate, rotate, or scale the curve.  

NOTE: If you created the spline IK handle with Root on Curve off in the tool options, translating, 

rotating, and scaling the curve does not translate the start joint. 

 

Example workflow: Use the advanced Spline IK twist controls to 

animate a snake 

A snake character with Spline IK slithers across the forest floor. The snake is manipulated by 

translating and rotating the NURBS curve. The NURBS curve is driven by control objects (in this 

example, they are locators) at the beginning (head) and end (tail) of the curve. 

1. Select the snake character’s Spline IK handle. 

 

The Spline IK handle starts at the first joint and ends at the last joint of the snake’s skeleton, and 

its NURBS curve runs through all the joints and bones. 

2. In the Attribute Editor, select the ikHandle node. 

3. In the IK Solver Attributes, click the Add Advanced Twist Control button. 

The advanced Spline IK twist control attributes appear. 
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4. Set the World Up Type to Object Rotation Up (Start/End). 

5. Choose Positive X and Positive Y from the Up Axis and Forward Axis drop-down lists, 

respectively. 

This constrains the start and end joint Up vectors of the snake's joints to the X and Y-axes of the 

locators used to drive the NURBS curve. 

NOTE: The Forward Axis and Up Axis attributes specify what local joint axes are aligned with the 

Up Object vectors specified in the Up Vector fields. 

6. Type the name of the head locator in the World Up Object field and the tail locator in the World Up 

Object 2 field. 

The positive Y orientation of the locators is used to calculate the Up vectors of the joints in the 

snake’s skeleton. 

NOTE: You can specify a specific vector offset for the joints with the Up Vector and Up Vector 

2 fields. 

7. Select and move the head locator. 

This moves all the joints and bones in the snake’s skeleton. Notice that the joints and bones also 

now respect the orientation of the manipulation objects. 

 

Example workflow: Use the advanced Spline IK twist controls to 

animate a snake 

 

A snake character with Spline IK slithers across the forest floor. The snake is manipulated by 

translating and rotating the NURBS curve. The NURBS curve is driven by control objects (in this 

example, they are locators) at the beginning (head) and end (tail) of the curve. 

1. Select the snake character’s Spline IK handle. 

www.a2zpapers.com
Download free old Question papers gndu, ptu hp board, punjab board

w
w
w
.
a
2
z
p
a
p
e
r
s
.
c
o
m

www.a2zpapers.com

a2zpapers.com

http://a2zpapers.com/
www.a2zpapers.com
http://a2zpapers.com/


 

The Spline IK handle starts at the first joint and ends at the last joint of the snake’s skeleton, and 

its NURBS curve runs through all the joints and bones. 

2. In the Attribute Editor, select the ikHandle node. 

3. In the IK Solver Attributes, click the Add Advanced Twist Control button. 

The advanced Spline IK twist control attributes appear. 

 

4. Set the World Up Type to Object Rotation Up (Start/End). 

5. Choose Positive X and Positive Y from the Up Axis and Forward Axis drop-down lists, 

respectively. 

This constrains the start and end joint Up vectors of the snake's joints to the X and Y-axes of the 

locators used to drive the NURBS curve. 

NOTE: The Forward Axis and Up Axis attributes specify what local joint axes are aligned with the 

Up Object vectors specified in the Up Vector fields. 

6. Type the name of the head locator in the World Up Object field and the tail locator in the World Up 

Object 2 field. 
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The positive Y orientation of the locators is used to calculate the Up vectors of the joints in the 

snake’s skeleton. 

NOTE: You can specify a specific vector offset for the joints with the Up Vector and Up Vector 

2 fields. 

7. Select and move the head locator. 

This moves all the joints and bones in the snake’s skeleton. Notice that the joints and bones also 

now respect the orientation of the manipulation objects. 

 

2 Bone IK solver 

The 2 bone solver is ideal for posing joint chains (such as arms and legs) that you want to stay in the 

same plane. For example, the shoulder, elbow, and wrist joints of an arm driven by a rotate plane IK 

handle all stay within the same plane as the elbow rotates. The plane itself can be rotated from the 

shoulder joint by the pole vector. 

The 2 bone IK solver is a subset of the rotate plane IK solver. Therefore, IK handles with the 2 bone 

IK solver solve the rotations of their joint chains in the same manner as a rotate plane IK handle. 

See Rotate Plane IK solver and Rotate Plane IK handle components. 

The two bone IK handle is meant for posing and animating short joint chains that consist of three 

joints (two bones). If you try to pose and animate a longer joint chain with the two bone IK handle, 

then the 2 bone solver will solve for the rotations of only the start and second to last joints and will 

ignore all other joints in the joint chain. 

The 2 bone solver is the fastest IK solver in Maya. This makes two bone IK handles ideal for setting 

up characters in a game development environment. Maya includes the source code for the 2 bone IK 

solver plug-in so that game developers can replicate the exact behavior of this feature in a games 

engine or modify the code to create their own custom IK solvers. 

 

Spring IK solver 

The spring IK solver ( ikSpringSolver ) produces proportional rotations across all joints. This is useful 

when posing and animating limbs that have numerous joints such as insect legs. 

www.a2zpapers.com
Download free old Question papers gndu, ptu hp board, punjab board

w
w
w
.
a
2
z
p
a
p
e
r
s
.
c
o
m

www.a2zpapers.com

a2zpapers.com

file:///F:\MayaHelp2016_enu\index.html%23!\url=.\files\GUID-9942FFB5-65C2-46E2-B5A3-297667A9FB5D.htm
file:///F:\MayaHelp2016_enu\index.html%23!\url=.\files\GUID-9942FFB5-65C2-46E2-B5A3-297667A9FB5D.htm
http://a2zpapers.com/
www.a2zpapers.com
http://a2zpapers.com/


 

The spring IK solver keeps the angles between joints in its joint chain proportional by 

applying bias values to those angles. This ensures that the angles between all joints are always 

evenly distributed. The spring IK solver is similar to the rotate plane IK solver in that both their IK 

handles have pole vectors. Since the spring IK handle has a pole vector, flipping will occur if the 

spring IK joint chain crosses its pole vector. 

An IK handle using the spring IK solver requires a rest pose. By default, the position and orientation of 

the target joint chain at the time of the spring IK handle’s creation is its rest pose. The distance 

between the first and last joint of a spring IK joint chain at its rest pose determines if the joint chain 

is flexed or extended, and influences each individual joint’s movement. 

 

 

Multi-chain IK solver 

The multi-chain solver can solve for multiple IK handles simultaneously. You can use the multi-chain 

IK handles to animate complex motions such as those of the tentacles of an octopus character. 
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An IK handle with the multi-chain solver manages the joints in its joint chain in the same manner as 

a single chain IK handle. See Single Chain IK solver. 

NOTE:The IK handle's Priority and Weight attributes apply only to the multi-chain IK solver. 

Forward kinematics (FK) 

 

With forward kinematics (FK), you rotate or move individual joints to pose and animate your joint 

chains. Moving a joint affects that joint and any joints below it in the hierarchy. 

For example, if you want a joint chain to reach for a particular location in space, you have to rotate 

each joint individually so that the joint chain can reach the location. To do this, you rotate and 

translate the joint chain’s parent joint, then the next joint, and so on down the joint chain. When you 

animate a skeleton using forward kinematics, Maya interpolates the joint rotations starting with the 

root joint, then the root’s child joints, and so on down through the skeleton’s hierarchy. 

Forward kinematics is ideal for creating non-directed motion (such as the rotations of a shoulder joint), 

and should not be used to animate a large, complicated skeleton. Also, forward kinematics is difficult 

to use for specifying goal-directed motion. For example, if you use FK to animate a skeleton, it is 

difficult to keep a foot still when the body moves forward. Also, when you think about moving your 

hand to some location in space, you don’t normally think about how you are going to rotate all the 

joints in your arm. 

 

To pose and animate a joint with forward kinematics 

1. Select the joint you want to animate. 

2. Select the Rotate Tool (hotkey: e) from the Tool Box. 

The rotation transform manipulators appear. 
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3. Advance the current time indicator along the Time Slider to the point in time where you would like 

to set a key. 

4. Rotate the joint to pose the current joint and all its child joints and then set a key (hotkey: s). 
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